C3 Vette Registry - The Best Resource on the Net for C3 Vettes! C3 Vette
Forums -> C3 Cooling and Heating Systems
Not Logged In! Login or Register!  Users Online: 15 / Help 
Features  Find C3 Parts on ebay in only 2 or 3 clicks!  | Add YOUR C3 to the Registry

Supporting Vendors
Mid America Motorworks
Bair's Corvettes
CorvetteClothing.com
Volunteer Vette Products
VetteBookStore.com

C3 of the Month
None Current
Enter Yours Today!
Online C3 Show
13
C3s are Registered

Vanity Plates
1981 CPE
Burkey
Featured Links

Buy Now
Motor Trend - $5 for 12 issues.
Motor Trend
Only $5 for 12 issues.


Chevrolet Corvette Restoration Guide
Chevrolet Corvette Restoration Guide


Corvette Fifty Years (Hardcover)
Corvette Fifty Years (Hardcover)


The Corvette Dynasty (Hardcover)
The Corvette Dynasty (Hardcover)



| Hide Signatures and Profile Pics

 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
8/10/09 3:55pm - Original Message: 'AC Not Blowing??'
Phill's Vette Lifetime Member
Lifetime Member
- Send Private Message


Apache Junction, AZ - USA

Vette(s):
1982,150K,Renegade CFI,Hooker Side Pipes,85 fuel pump,Bilsteins,HD suspension, Aluminum radiator, SharkBar/w 5-Point Restraints. 3:73 gears coming soon.

Joined: 10/15/2006
Posts: 285
My AC was blowing this morning, now it's not.
How can I tell if it is a switch or if it is the fan? Which switched do I check?

Thanks!

Signed,
Hot & Sweaty in AZ....
Dead
 Reply Reply  Quote Reply w/Quote
 
Support C3VR!
Suport our advertisers
8/10/09 4:05pm - Reply: 'AC Not Blowing??'
dskopp
Former Member
- Send Private Message


Oak Creek, WI - USA

Vette(s):
1981 Great White Shark. Red Interior, 350/190hp. PS, PB (SS), A/C CC, T-Tops, Going to remain as Stock as possible. Served three years in Active Duty Army, then Retired Air Force after 34 years! Badger State Vetts Car Club. 175,000 Original miles!!

Joined: 5/21/2008
Posts: 1956
1st of all check the fuse in the fuse block on the lower drivers side of the car.  What does that tell you?

____________________________________
          



(click to see a larger image)
 Reply Reply  Quote Reply w/Quote
8/10/09 7:34pm - Reply: 'AC Not Blowing??'
Phill's Vette Lifetime Member
Lifetime Member
- Send Private Message


Apache Junction, AZ - USA

Vette(s):
1982,150K,Renegade CFI,Hooker Side Pipes,85 fuel pump,Bilsteins,HD suspension, Aluminum radiator, SharkBar/w 5-Point Restraints. 3:73 gears coming soon.

Joined: 10/15/2006
Posts: 285
Got further under the hood today and it looks/sounds like the blower motor went bad. It has a quiet grinding sound, but still lightly blows. I will get a replacement motor ordered tomorrow and get to work.

  New question: Any tricks and tips to replacing the blower fan motor? It doesn't look easy, but the accumulator replacement I just did last month wasn't easy either. I have all the shop/service manuals and will be reading up.
It just couldn't wait until winterAngry

Thanks!
Thumbs Up 


____________________________________
LifeTime Member #154


Number 28 of 200 Made on July 28th, 1982
P E A C E !
Phill
 Reply Reply  Quote Reply w/Quote
8/10/09 10:50pm - Reply: 'AC Not Blowing??'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19449
The high speed blower, and all the other speeds, work off of different circuits, so it's possible to have NO high speed, but all the other speeds, as is it possible to have only high speed, but no other speeds.
The blower motor should be running any time the key is on, on LOW speed, so...what you're hearing may be just the normal, low speed of the blower.
What does it do if you try the other speeds? Does the sound change any at all? If it does, then the switch is prolly otay, and the blower motor is prolly toast. If it doesn't, then you may need to do some testing. First, tho, make sure the ground wire that is screwed in with one of the blower motor bolts is nice and tight...that wire can get loose, and cause the same sympthoms....
You can run a jumper wire to the motor with 12v, and it should spin like it does with the switch on 'High". If it don't, then the motor is definitely bad.

As far as changing the blower motor, it's not exactly the most fun job, but it beats the h ell out of working under the dash! You may need to move some stuff out of the way to get the motor all the way out past the fender, like the coolant bottle, and you may find that your hands/arms don't bend the way you need them to, to get to the bolts...


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
8/10/09 11:26pm - Reply: 'AC Not Blowing??'
Phill's Vette Lifetime Member
Lifetime Member
- Send Private Message


Apache Junction, AZ - USA

Vette(s):
1982,150K,Renegade CFI,Hooker Side Pipes,85 fuel pump,Bilsteins,HD suspension, Aluminum radiator, SharkBar/w 5-Point Restraints. 3:73 gears coming soon.

Joined: 10/15/2006
Posts: 285

  I removed the motor and fan impeller and the problem was the nut holding the impeller to the motor shaft was MIA. This was causing the impeller to bounce and rub in the housing. Everything went back together good and tight, including the impeller; I used a drop of thread lock so it should never come off the shaft. 
FYI: Motor was accessible buy taking off the right side fender vent, coolant tank and compressor mount bolts - STILL easier than under dash work!!phew 

Joel,
I installed a new speed switch last year because I had no low speeds - only high speed. The switch was not the problem as I still have only high speed. What would be the cause of this and what should I check?

Thanks for the help!
Thumbs Up


Phill's Vette2009-08-10 20:28:41

____________________________________
LifeTime Member #154


Number 28 of 200 Made on July 28th, 1982
P E A C E !
Phill
 Reply Reply  Quote Reply w/Quote
8/11/09 7:56am - Reply: 'AC Not Blowing??'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19449
No low/med/med-high speed is normally caused by a bad resistor, if the switch is good, and there is power to it. The resistor coils are usually inside the evaporator box/housing, under the hood. They have a tendency to get corroded, and not make good contact with the crimped connections on the ends of the coils. Ya might pull that out and have a look-see. Look for a small, rectangular shaped block with a wiring connector on it, normally pointing straight down, in the top of the evaporator housing. I think there was some pics posted in another thread a while back.

The high speed blower is on a separate circuit, and runs thru a relay, which is why you can have some speeds working, and not others.


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
8/11/09 9:30am - Reply: 'AC Not Blowing??'
crossfire1982
Standard Member
- Send Private Message


Cramerton, NC - USA

Vette(s):
black 1982 coupe slate gray interior, 350 crossfire, 1985 fuel pump, Steeroids R&P conversion

Joined: 8/22/2006
Posts: 1094
Phill, I had similar problems a year or so back. In the fan circuit there is a RELAY that is mounted on the firewall and on your 82 is attached to the plastic wiring harness cover on the passengers side of the distributor.  This relay on mine was not working correctly.  I removed the relay cover and used fine abrasive paper to clean the contacts, and its worked great ever since.  The solderless connectors on the RESISTOR are bad to get corroded as well, give them the wiggle test to see if that may be  your problem.

____________________________________

Click for a larger image
Save The Wave


 Reply Reply  Quote Reply w/Quote
8/11/09 11:21am - Reply: 'AC Not Blowing??'
74-454 Lifetime Member
Lifetime Member
- Send Private Message


, - Canada

Vette(s):
Coupe 74 - 454 Drive it like you stole it!

Joined: 8/6/2004
Posts: 533
Same here; only the high speed was not working.  When I removed the cover of the relay; they whole thing fell apart; it was cracked in half (the bottom being plastic I guess).  Those relay are not cheap if my memory serves me right.

Anyway, I still don't have A/C, but I fixed the problem by driving faster and without the tops!
 Reply Reply  Quote Reply w/Quote
8/11/09 5:55pm - Reply: 'AC Not Blowing??'
Phill's Vette Lifetime Member
Lifetime Member
- Send Private Message


Apache Junction, AZ - USA

Vette(s):
1982,150K,Renegade CFI,Hooker Side Pipes,85 fuel pump,Bilsteins,HD suspension, Aluminum radiator, SharkBar/w 5-Point Restraints. 3:73 gears coming soon.

Joined: 10/15/2006
Posts: 285
Thanks for the links Chip! I think I will go ahead and order the relay and resister - might as well as I have invested this deep into the AC already.

  I tried the high speed without tops and all I got was $580 in excessive speed acknowledgments from the Arizona highway patrol......Wits End


____________________________________
LifeTime Member #154


Number 28 of 200 Made on July 28th, 1982
P E A C E !
Phill
 Reply Reply  Quote Reply w/Quote
 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
 Forums -> C3 Cooling and Heating Systems
(Moderator: Adam Wartell, Norsky, Adams' Apple)
 

 
Official C3 Vette Registry Community:
Home | Forums | Email | Who's Online | Clubs | Events | Member Stats

Other Official C3 Vette Registry Areas:
Members | Research | Shop | My Account | About C3VR
 

Corvette is a registered trademark of the General Motors Corporation(GM) & Chevrolet Motor Division. Vette Registries, LLC is responsible for all site content (except for member submitted content or where otherwise noted) and does not claim or imply that Chevrolet or GM is responsible for Official C3 Vette Registry content. Vette Registries, LLC is independent from GM and is not affiliated with, sponsored or supported by GM.  Copyright/trademark/sales mark infringements are not intended, or implied and are in fact used to support GM, Chevrolet and Corvette

Official C3 Vette Registry content is Copyright 2001-2017, Vette Registries, LLC. Content may not be reused without written consent. All Rights Reserved. NS

Corvette (Vette) Model Years on this site: 1968 1969 1970 1971 1972 1973 1974 1975 1976 1977 1978 1979 1980 1981 1982 30