C3 Vette Registry - The Best Resource on the Net for C3 Vettes! C3 Vette
Forums -> C3 Electrical
Not Logged In! Login or Register!  Users Online: 18 / Help 
Features  Find C3 Parts on ebay in only 2 or 3 clicks!  | Add YOUR C3 to the Registry

Supporting Vendors
VetteBookStore.com
CorvetteClothing.com
Mid America Motorworks
Volunteer Vette Products
Bair's Corvettes

C3 of the Month
None Current
Enter Yours Today!
Online C3 Show
13
C3s are Registered

Vanity Plates
7D7
madjaxs
Featured Links

Buy Now
Collector's Originality Guide Corvette 1968-1982 (Paperback)
Collector's Originality Guide Corvette 1968-1982 (Paperback)


Corvette by the Numbers
Corvette by the Numbers


Corvette Fifty Years (Hardcover)
Corvette Fifty Years (Hardcover)


Motor Trend - $5 for 12 issues.
Motor Trend
Only $5 for 12 issues.



| Hide Signatures and Profile Pics

 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
2/7/14 4:55pm - Original Message: '75 Corvette instrument lights don't work'
Vetteman75 Gold Member
Gold Member
- Send Private Message


Wetumpka, AL - USA

Vette(s):
1975 Stingray Coupe 2014 Stingray Convertible

Joined: 1/9/2014
Posts: 16
I have 75 Vette that the instrument lights don't work.  I have the speedometer and tach out of the Vette.  I bought a new light switch hoping that would do the trick.  It still doesn't work.  Does the dash have to be back on the vehicle to make the bulbs work?  I noticed that only one side of the fuse appears to have power (originally there were no fuse).  I have never seen anything like this?  Also there were two bulbs to the left side by gauges (and they had two wires in them) wires not the gray ones to the dash lights.  They didn't have bulbs in them so I put some in.  One lighted up.  Also I noticed that when I checked the gray wire with light tester I did have power to sockets but the bulbs wouldn't light up (with a new light switch can you light them up without putting the dash back into the car?)   I am thinking I have a ground problem.  Do you know where I should look for the ground wire for the instrument lights.  Any help you can give me will be great.  I do have a fluke meter as well.  Also the turn signal lights use to blink on the instrument panel however they don't blink now that the dash is out.  The turn signals work in the front/back of car.  Need your help.

Thanks Dean



|UPDATED|2/7/2014 1:55:34 PM (AZT)|/UPDATED|


____________________________________
 Reply Reply  Quote Reply w/Quote
 
Support C3VR!
Suport our advertisers
2/7/14 5:50pm - Reply: 'Re: 75 Corvette instrument lights don't work'
dyoes
Former Member
- Send Private Message


Zachary, LA - USA

Vette(s):
1974 L-48 Auto. Just your basic Vette. GM crate motor w/vortec heads and intake. Crane cam. Scorpion rockers, Edelbrock carb. Lots of parts still in boxes... :(

Joined: 1/27/2013
Posts: 201
The bulbs get ground from the tach and speedo housings.  There are heavier black wires in the harness with a spade connector on them that plug into the tach and speedo. 

So if the lights are not plugged into the gauges, they won't light up because they'll have no ground (note that there is only a single wire going to them).  If I remember right, the parking brake warning light has two wires.

Take a piece of wire, ground it to the car somewhere, and touch it to the metal barbs on each instrument light wire (with the lights on).  They should light up!

____________________________________


"Let them that don't want none have memories of not gettin' any."
- Brother Dave Gardner

 Reply Reply  Quote Reply w/Quote
2/7/14 6:29pm - Reply: 'Re: 75 Corvette instrument lights don't work'
Vetteman75 Gold Member
Gold Member
- Send Private Message


Wetumpka, AL - USA

Vette(s):
1975 Stingray Coupe 2014 Stingray Convertible

Joined: 1/9/2014
Posts: 16
dyoes,

Thanks for the reply however, I did what you said but they still wont light up.  The fuse is hot and so are the gray sockets with the tester however put a bulb in there and it will not light up.  I checked them all and they are hot.  I ground a wire and tried touching the bulb socket and even bulb but no luck.  I don't want to put this back together unless I know it is working.  Anymore suggestions?



____________________________________
 Reply Reply  Quote Reply w/Quote
2/7/14 8:52pm - Reply: 'Re: 75 Corvette instrument lights don't work'
dyoes
Former Member
- Send Private Message


Zachary, LA - USA

Vette(s):
1974 L-48 Auto. Just your basic Vette. GM crate motor w/vortec heads and intake. Crane cam. Scorpion rockers, Edelbrock carb. Lots of parts still in boxes... :(

Joined: 1/27/2013
Posts: 201
The bulbs should look like this:



Except the wire is grey.  If you have power to the center of that socket (+12v) and a good bulb, there is no reason it shouldn't work.  You have to touch the ground wire to the little metal prongs surrounding the bulb though, not the plastic of the socket.

Are you sure your ground wire is on a good ground?

Again, there is no way it can't work if the bulb is good, 12v to the center of the socket, and a good ground.


____________________________________


"Let them that don't want none have memories of not gettin' any."
- Brother Dave Gardner

 Reply Reply  Quote Reply w/Quote
2/7/14 11:31pm - Reply: 'Re: 75 Corvette instrument lights don't work'
Vetteman75 Gold Member
Gold Member
- Send Private Message


Wetumpka, AL - USA

Vette(s):
1975 Stingray Coupe 2014 Stingray Convertible

Joined: 1/9/2014
Posts: 16

Doyes, that is what I have been saying it doesn't make sense to me that it doesn't work.  I will go back out there and try to ground it some place else.  I have power to the center of that socket but it will not light that bulb.  I bought new ones and they don't work either.  I haven't given up yet at least I must be close to seeing them work.   Thanks again for you support and help.  Dean



____________________________________
 Reply Reply  Quote Reply w/Quote
2/7/14 11:57pm - Reply: 'Re: 75 Corvette instrument lights don't work'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19449
How are you testing for power at the socket? Test light, or multimeter?
Even checking with a multimeter, and showing full battery voltage(12+v), a bad connection can cause the lights to not shine. The wiring, including all connections(including the socket itself) must be able to carry the amperage/load once the light is "on". If you have a solid 12v at the center terminal of the socket(measured from the bulb side), and a good ground, the lamp has to light. If you lose your 12v power while under a load(bulb in, power and ground supplied), then you have a bad connection somewhere.
Try this. Connect the positive lead of your multimeter to your makeshift ground wire, and connect one end of the ground wire to the metal tangs of the socket, but leave the other end of your ground wire loose. Put your ground lead for the multimeter to a good ground(the battery is best). Turn the lights on. You should have 12v showing. Then put the loose end of your ground wire to a good ground. Your voltage should go to zero....and the bulb should burn.
What we're attempting to do here is verify that you have 12v THRU the socket.

____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
2/7/14 11:58pm - Reply: 'Re: 75 Corvette instrument lights don't work'
Vetteman75 Gold Member
Gold Member
- Send Private Message


Wetumpka, AL - USA

Vette(s):
1975 Stingray Coupe 2014 Stingray Convertible

Joined: 1/9/2014
Posts: 16
Doyel,

Houston we have lights.  You know I purchased some new Super Green 3SMD 2835 LED Instrument Panel BA9S 2835 Light Bulb 1895 off Ebay.  I was going to replace the original bulbs with them.  Yesterday when I put one in and I didn't ground it.  Tonight when I got home I went back out there and put 2 new LED bulbs in grounded them and they worked.  Do you think I can use the LED's or should I just put original bulbs back in?  I guess the bulbs were all bad.  My 75 is painted GM 42, Bright Green Metallic and I thought it would look cool with a green dash.  Let me know what your thoughts are on replacing them with the LED or leave it original?   Will they get to hot?  I am just glad that I got it working.  Dean




____________________________________
 Reply Reply  Quote Reply w/Quote
2/8/14 12:19am - Reply: 'Re: 75 Corvette instrument lights don't work'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19449
Glad they are now working! Thumbs Up

You can use the LED bulbs with no problem, except you will not be able to dim them.....they will be either on, or off, without some sort electronic converter/dimmer. The headlight switch will not do it.


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
2/8/14 11:38pm - Reply: 'Re: 75 Corvette instrument lights don't work'
dyoes
Former Member
- Send Private Message


Zachary, LA - USA

Vette(s):
1974 L-48 Auto. Just your basic Vette. GM crate motor w/vortec heads and intake. Crane cam. Scorpion rockers, Edelbrock carb. Lots of parts still in boxes... :(

Joined: 1/27/2013
Posts: 201
Bad bulbs... Whoda thunk?  Glad they're working!  Handshake

The LEDs will actually run a lot cooler than incandescent bulbs and draw a lot less power. 


____________________________________


"Let them that don't want none have memories of not gettin' any."
- Brother Dave Gardner

 Reply Reply  Quote Reply w/Quote
2/12/14 1:46am - Reply: 'Re: 75 Corvette instrument lights don't work'
HighDesertDave
Former Member
- Send Private Message


Carson City, NV - USA

Vette(s):
Numbers matching 1972 350 4 speed, silver pewter body with blue interior

Joined: 12/4/2013
Posts: 239
Glad to see there is another fighting with dash bulbs! If you go LED please post your thoughts. I'm on the fence. Whoever posted the solid black ground wire with spade connector comment....thanks! I buttoned up my gauge panel and I found one unconnected black wire with spade and for the life of me couldn't figure out where it went. Hope I can find the brass terminal without pulling the gauge panel. Its sooooo darn tight up there!

____________________________________
My Christmas present to ME! Bought Sat 11-30-2013. 72, 350 4 spd, Silver with blue interior...Can't you just hear Pablo Cruz playing in the background?

 Reply Reply  Quote Reply w/Quote
2/12/14 10:38pm - Reply: 'Re: 75 Corvette instrument lights don't work'
rlu1968
Standard Member
- Send Private Message


Gordonvillle, TX - USA

Vette(s):
1968 Roadster 427

Joined: 11/28/2003
Posts: 222
I don't know about the 74-75 but the 68 has a spade ground connection on the speedometer, and the tach housing. If either ground is not connected than you will not have dash lights. 
 You also have ring ground connection to the metal housing above the drivers vent and another ground on your head light and windshield wiper override switch. Most electrical problems that I have encountered come from not having a proper ground. 


____________________________________

 Reply Reply  Quote Reply w/Quote
2/14/14 1:21pm - Reply: 'Re: 75 Corvette instrument lights don't work'
rraider1
Former Member
- Send Private Message


Woodland, WA - USA

Vette(s):
1977 T-Top,350,Auto Black Ruby Pearl,Steeroids R&P conversion

Joined: 10/14/2003
Posts: 1152
This might help




____________________________________
Bob R
 Reply Reply  Quote Reply w/Quote
2/14/14 1:28pm - Reply: 'Re: 75 Corvette instrument lights don't work'
Vetteman75 Gold Member
Gold Member
- Send Private Message


Wetumpka, AL - USA

Vette(s):
1975 Stingray Coupe 2014 Stingray Convertible

Joined: 1/9/2014
Posts: 16

Thanks everyone for the replies I have this one under control with everyone's help.  Thanks again Dean



____________________________________
 Reply Reply  Quote Reply w/Quote
 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
 Forums -> C3 Electrical
(Moderator: Adam Wartell, Norsky, Adams' Apple)
 

 
Official C3 Vette Registry Community:
Home | Forums | Email | Who's Online | Clubs | Events | Member Stats

Other Official C3 Vette Registry Areas:
Members | Research | Shop | My Account | About C3VR
 

Corvette is a registered trademark of the General Motors Corporation(GM) & Chevrolet Motor Division. Vette Registries, LLC is responsible for all site content (except for member submitted content or where otherwise noted) and does not claim or imply that Chevrolet or GM is responsible for Official C3 Vette Registry content. Vette Registries, LLC is independent from GM and is not affiliated with, sponsored or supported by GM.  Copyright/trademark/sales mark infringements are not intended, or implied and are in fact used to support GM, Chevrolet and Corvette

Official C3 Vette Registry content is Copyright 2001-2017, Vette Registries, LLC. Content may not be reused without written consent. All Rights Reserved. NS

Corvette (Vette) Model Years on this site: 1968 1969 1970 1971 1972 1973 1974 1975 1976 1977 1978 1979 1980 1981 1982 30