C3 Vette Registry - The Best Resource on the Net for C3 Vettes! C3 Vette
Forums -> C3 Electrical
Not Logged In! Login or Register!  Users Online: 18 / Help 
Features  Find C3 Parts on ebay in only 2 or 3 clicks!  | Add YOUR C3 to the Registry

Supporting Vendors
Mid America Motorworks
Volunteer Vette Products
CorvetteClothing.com
VetteBookStore.com
Bair's Corvettes

C3 of the Month
None Current
Enter Yours Today!
Online C3 Show
13
C3s are Registered

Vanity Plates
RARE81
Rare81
Featured Links
Chevrolet Corvette Restoration Guide


Buy Now
Chevrolet Corvette: 1968 thru 1982, All V8 models (Haynes Manuals) (Paperback)
Chevrolet Corvette: 1968 thru 1982, All V8 models (Haynes Manuals) (Paperback)


The Corvette Dynasty (Hardcover)
The Corvette Dynasty (Hardcover)


GM Corvette 1963-82 (Chilton's Total Car Care Repair Manuals) (Paperback)
GM Corvette 1963-82 (Chilton's Total Car Care Repair Manuals) (Paperback)


The Corvette Factories: Building America's Sports Car (Hardcover)
The Corvette Factories: Building America's Sports Car (Hardcover)



| Hide Signatures and Profile Pics

 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
11/28/12 5:31pm - Original Message: 'Oil Pressure Gauge - pegged to the right/inoperative'
airmed_pilot1
Former Member
- Send Private Message


Joined: 11/17/2012
Posts: 24

Need help troubleshooting faulty oil pressure gauge.

Symptom: Gauge "parked" at the 3:00 o'clock position whether engine is running or off.
When starting engine, the gauge momentarily moves/bounces perhaps +/- 5 degrees from the 3:00 o'clock position, then parks itself back in the 3:00 o'clock position, where it remains motionless.
 
Actual engine oil pressure is tests good/strong. 
Connection to sensor appears fine.
Replaced Oil Pressure Sending Unit approximately one year ago
 
Any ideas or suggestions? Is this what a bad oil pressure gauge looks like?
 


____________________________________


(click to see a larger image)

 Reply Reply  Quote Reply w/Quote
 
Support C3VR!
Suport our advertisers
11/28/12 11:27pm - Reply: 'Re: Oil Pressure Gauge - pegged to the right/inoperative'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19449
Disconnect the sensor at the sending unit, and turn the key on. If the gauge acts the same way, then either gauge is messed up, or there is a short in the wiring between the gauge and the sender.Could also be the connection on the rear of the gauge cluster(printed circuit board).

|UPDATED|11/28/2012 8:27:49 PM (AZT)|/UPDATED|


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
11/29/12 12:05pm - Reply: 'Re: Oil Pressure Gauge - pegged to the right/inoperative'
airmed_pilot1
Former Member
- Send Private Message


Joined: 11/17/2012
Posts: 24
Thank you, Joel. Hopefully I can find time to check it out this weekend.

____________________________________


(click to see a larger image)

 Reply Reply  Quote Reply w/Quote
11/29/12 7:06pm - Reply: 'Re: Oil Pressure Gauge - pegged to the right/inoperative'
Jeffm Gold Member
Gold Member
- Send Private Message


Sebago Lake, ME - USA

Vette(s):
1978 Silver Anniversary L82 4spd (M21) Red Leather. -1978 Pace Car L82 4spd (M21) 20k miles.

Joined: 2/15/2007
Posts: 962
Mine was the circuit board that Joel mentioned. As I recall I think the needle did just stay up high. The green plastic board was dried out and some of the copper strips were flaking off.  New board did the trick.

____________________________________


 Reply Reply  Quote Reply w/Quote
1/12/13 4:55pm - Reply: 'Re: Oil Pressure Gauge - pegged to the right/inoperative'
airmed_pilot1
Former Member
- Send Private Message


Joined: 11/17/2012
Posts: 24
Turned out to be the oil pressure sending unit. Swap for new unit fixed the issue.

____________________________________


(click to see a larger image)

 Reply Reply  Quote Reply w/Quote
 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
 Forums -> C3 Electrical
(Moderator: Adam Wartell, Norsky, Adams' Apple)
 

 
Official C3 Vette Registry Community:
Home | Forums | Email | Who's Online | Clubs | Events | Member Stats

Other Official C3 Vette Registry Areas:
Members | Research | Shop | My Account | About C3VR
 

Corvette is a registered trademark of the General Motors Corporation(GM) & Chevrolet Motor Division. Vette Registries, LLC is responsible for all site content (except for member submitted content or where otherwise noted) and does not claim or imply that Chevrolet or GM is responsible for Official C3 Vette Registry content. Vette Registries, LLC is independent from GM and is not affiliated with, sponsored or supported by GM.  Copyright/trademark/sales mark infringements are not intended, or implied and are in fact used to support GM, Chevrolet and Corvette

Official C3 Vette Registry content is Copyright 2001-2017, Vette Registries, LLC. Content may not be reused without written consent. All Rights Reserved. NS

Corvette (Vette) Model Years on this site: 1968 1969 1970 1971 1972 1973 1974 1975 1976 1977 1978 1979 1980 1981 1982 30