C3 Vette Registry - The Best Resource on the Net for C3 Vettes! C3 Vette
Forums -> C3 Electrical
Not Logged In! Login or Register!  Users Online: 13 / Help 
Features  Find C3 Parts on ebay in only 2 or 3 clicks!  | Add YOUR C3 to the Registry

Supporting Vendors
CorvetteClothing.com
Mid America Motorworks
VetteBookStore.com
Bair's Corvettes
Volunteer Vette Products

C3 of the Month
None Current
Enter Yours Today!
Online C3 Show
13
C3s are Registered

Vanity Plates
ILRUNYA
bradjarmstrong
Featured Links

Buy Now
Corvette 50th Anniversary
Corvette 50th Anniversary


Corvette Magazine - $19.99 for 8 issues
Corvette Magazine
Only $19.99 for 8 issues


The Corvette Dynasty (Hardcover)
The Corvette Dynasty (Hardcover)


How To Rebuild Corvette Rolling Chassis 1963-1982
How To Rebuild Corvette Rolling Chassis 1963-1982



| Hide Signatures and Profile Pics

 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
12/9/13 3:12pm - Original Message: 'Static on Retro Model 2 Radio'
dapperdan
Former Member
- Send Private Message


COLUMBUS, NC - USA

Vette(s):
2011 Grand Sport Coupe, 6-speed 1977 Coupe L82, 4-speed

Joined: 8/19/2012
Posts: 42
I successfully installed a RetroSound Model 2 radio in my '77, with 2 new Polk speakers also.  Everything appears to be working OK, except I am getting quite a bit of static when playing the radio, regardless of the station.  The sound is just fine when playing a song with an iPod.  I'm guessing that there is a problem with the antenna?  Perhaps a bad cable or some problem with the mount.  I have done nothing with the antenna.  The original radio did not work at all.  Any suggestions would be appreciated.

____________________________________
 Reply Reply  Quote Reply w/Quote
 
Support C3VR!
Suport our advertisers
12/9/13 3:27pm - Reply: 'Re: Static on Retro Model 2 Radio'
rraider1
Former Member
- Send Private Message


Woodland, WA - USA

Vette(s):
1977 T-Top,350,Auto Black Ruby Pearl,Steeroids R&P conversion

Joined: 10/14/2003
Posts: 1152

you might try to clean the ground plane and the ground for it. here is a picture of what's back their

http://www.C3VR.com/member_pages/4201_4300/4221/68-77-Antenna.jpg 



____________________________________
Bob R
 Reply Reply  Quote Reply w/Quote
12/19/13 8:40am - Reply: 'Re: Static on Retro Model 2 Radio'
slofut
Former Member
- Send Private Message


Moultrie, GA - USA

Vette(s):
1971 vert, 350/350, conversion to LS1/t56, ontario orange/dark saddle

Joined: 1/18/2013
Posts: 2
dapperdan said: I successfully installed a RetroSound Model 2 radio in my '77, with 2 new Polk speakers also.  Everything appears to be working OK, except I am getting quite a bit of static when playing the radio, regardless of the station.  The sound is just fine when playing a song with an iPod.  I'm guessing that there is a problem with the antenna?  Perhaps a bad cable or some problem with the mount.  I have done nothing with the antenna.  The original radio did not work at all.  Any suggestions would be appreciated.


Is the "static" only with the engine running? And is the noise a whine or buzz like alternator noise, or is it more of a coarse type of noise that would be coming from the coil/dist/HT circuit? Check antenna plug behind the radio for proper ground/shield connection, and integrity all the way back to the ground plane like rraider said
Bill


|UPDATED|12/19/2013 6:40:01 AM (AZT)|/UPDATED|


____________________________________

 Reply Reply  Quote Reply w/Quote
12/19/13 10:13am - Reply: 'Re: Static on Retro Model 2 Radio'
dapperdan
Former Member
- Send Private Message


COLUMBUS, NC - USA

Vette(s):
2011 Grand Sport Coupe, 6-speed 1977 Coupe L82, 4-speed

Joined: 8/19/2012
Posts: 42
The static noise is not a constant buzz, or hum.  It is more like random "crackling."
I will have to check the ground at the back mount of the antenna, I guess.  I'm pretty sure that there is no problem with the connection at the radio.  There could be some issues along the path of the antenna wire.  I'll have to trouble shoot that too.


____________________________________
 Reply Reply  Quote Reply w/Quote
 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
 Forums -> C3 Electrical
(Moderator: Adam Wartell, Norsky, Adams' Apple)
 

 
Official C3 Vette Registry Community:
Home | Forums | Email | Who's Online | Clubs | Events | Member Stats

Other Official C3 Vette Registry Areas:
Members | Research | Shop | My Account | About C3VR
 

Corvette is a registered trademark of the General Motors Corporation(GM) & Chevrolet Motor Division. Vette Registries, LLC is responsible for all site content (except for member submitted content or where otherwise noted) and does not claim or imply that Chevrolet or GM is responsible for Official C3 Vette Registry content. Vette Registries, LLC is independent from GM and is not affiliated with, sponsored or supported by GM.  Copyright/trademark/sales mark infringements are not intended, or implied and are in fact used to support GM, Chevrolet and Corvette

Official C3 Vette Registry content is Copyright 2001-2017, Vette Registries, LLC. Content may not be reused without written consent. All Rights Reserved. NS

Corvette (Vette) Model Years on this site: 1968 1969 1970 1971 1972 1973 1974 1975 1976 1977 1978 1979 1980 1981 1982 30