C3 Vette Registry - The Best Resource on the Net for C3 Vettes! C3 Vette
Forums -> C3 Engines
Not Logged In! Login or Register!  Users Online: 17 / Help 
Features  Find C3 Parts on ebay in only 2 or 3 clicks!  | Add YOUR C3 to the Registry

Supporting Vendors
Bair's Corvettes
Mid America Motorworks
Volunteer Vette Products
VetteBookStore.com
CorvetteClothing.com

C3 of the Month
None Current
Enter Yours Today!
Online C3 Show
13
C3s are Registered

Vanity Plates
CURVY 79
curvy79
Featured Links

Buy Now
Kindle
Kindle


Corvette Magazine - $19.99 for 8 issues
Corvette Magazine
Only $19.99 for 8 issues


Chevrolet Corvette Restoration Guide
Chevrolet Corvette Restoration Guide


Corvette Fifty Years (Hardcover)
Corvette Fifty Years (Hardcover)



| Hide Signatures and Profile Pics

 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
6/4/11 2:45pm - Original Message: '82 Computer'
TommySSE
Former Member
- Send Private Message


Darnestown, MD - USA

Vette(s):
"Ruby", is my 1982 Candy Red - my Daily Driver

Joined: 1/1/2009
Posts: 32
How do I check the operating status of the 82 Computer?Ouch
Engine running like its on 6 cylinders - step on the gas a little and it back fires through throttlebody, like it sneezed, and pinging like crazy on 93 octane.  Was running on regular really nicely getting 20mpg with plenty of power.
I tried unplugging the battery a couple of times hoping it would reboot/reset the computer - no difference noticed.  I'm pulling the plugs, wires, dist cap, and rotor cause I saw a lot of shorting between the plug wires. found plugs that seemed fouled.
Using an "action code scanner" (CP9001) - the code pumped out 12 = computer error. 
The previous owner removed the cats - so my guess is that the computer may have been tampered with, cause what would you do about the O2 sensor at the cat? my bet is that the computer is looking for that O2 data.

Advice?

Does C3VR forum have a photo library (searchable) for wiring diagrams and other points of interest?
 Reply Reply  Quote Reply w/Quote
 
Support C3VR!
Suport our advertisers
6/4/11 6:12pm - Reply: '82 Computer'
rraider1
Former Member
- Send Private Message


Woodland, WA - USA

Vette(s):
1977 T-Top,350,Auto Black Ruby Pearl,Steeroids R&P conversion

Joined: 10/14/2003
Posts: 1152
From the information I have Code 12 is normal operation, if your wires are shorting then that would be a big issue, make sure the plug wires are for HEI, not sure hoping some CFI guys will chime in but once the computer is reset it needs to run for a will to relearn the system. from the discription it sound like you hav some bad wires.

____________________________________
Bob R
 Reply Reply  Quote Reply w/Quote
6/4/11 6:22pm - Reply: '82 Computer'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19449
Code 12 is simply a code that lets you know the ECM is in diagnostic mode...it means nothing else.
I agree with the plug wires causing the problem, too. Do the usual tune-up stuff first, since you know there is a problem there. The ECMs don't fail all that often, but they usually create more problems than you are having.

You can get the wiring diagrams Here....er...well...you COULD. Seems Ben's server is down at this time...
I can e-mail you the '82 diagram if ya want....


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
6/4/11 6:25pm - Reply: '82 Computer'
crossfire1982
Standard Member
- Send Private Message


Cramerton, NC - USA

Vette(s):
black 1982 coupe slate gray interior, 350 crossfire, 1985 fuel pump, Steeroids R&P conversion

Joined: 8/22/2006
Posts: 1094
Did the problem just appear suddenly or was anything changed prior to the problem appearing?  My factory service manual shows "Code 12 indicats that the distributor spark-tuning reference pulses, which are generated by the pickup coil, are not being received by the ECM".  Double check everything at the distributor including the coil.  Not sure if the ignition module in the base of the HEI distributor could cause this problem or not but they are very prone to fail and can cause erratic engine or a no start / no run condition.  The forum does not have an official photo library that Im aware of  but if you will tell me what you need if its for an 82 Ill see if I have anything that will help.
Crossfire19822011-06-05 06:49:49

____________________________________

Click for a larger image
Save The Wave


 Reply Reply  Quote Reply w/Quote
6/4/11 8:55pm - Reply: '82 Computer'
DaveM Lifetime Member
Lifetime Member
- Send Private Message


Flanders, NJ - USA

Vette(s):
1982 Black, ZZ4, Hooker Side Pipes, 3.55 Rear, Rebuilt & upgraded 700R4, All new suspension, brakes, & new Charcoal interior.

Joined: 1/27/2004
Posts: 2530
Having no Cat is not a problem, the O2 sensor is before the cat and works the same with or without the cat. I would start with a tune up with new wires, new coil & ign. module first.
Good luck,
Dave
DaveM2011-06-04 17:55:47

____________________________________
 

Lifetime Member #116
Dave's '82


   
 Reply Reply  Quote Reply w/Quote
6/4/11 11:39pm - Reply: '82 Computer'
TommySSE
Former Member
- Send Private Message


Darnestown, MD - USA

Vette(s):
"Ruby", is my 1982 Candy Red - my Daily Driver

Joined: 1/1/2009
Posts: 32
Thanks for the fast response - I'll keep checking in on the link you sent to catch it when it is back up.  And yes! I would really appreciate any diagrams you could share.

tthompsonsr@gmail.com




____________________________________
Tommy
1980 Project Corvette - (Need suggestions)
1982 "Ruby" (Ain't She Sweet!)
 Reply Reply  Quote Reply w/Quote
6/5/11 12:27am - Reply: '82 Computer'
TommySSE
Former Member
- Send Private Message


Darnestown, MD - USA

Vette(s):
"Ruby", is my 1982 Candy Red - my Daily Driver

Joined: 1/1/2009
Posts: 32
It kinda came on suddenly - At first I thought it was weather temperature related (really had me puzzled) - it seemed as though the computer was confused and couldn't make up its mind trying to figure out how it was deciding to run. Then after about 5 mins of this foolishness it would settle down and run good.  once the weather got warmer things were good. Then I had a chance to wash the engine with my handy dandy electric pressure washers. Then it began to run rough. Then quickly running like it is now - seeming like it is running on 6 cylinders. It always starts easily - nut runs terrible, weak, and sneezing when I put a little too much toe into the throttle (way less then normal).  
I guess I better replace the ignition module too while I'm in the distributor.

I have two requests for you - I gotta get an air cleaner like yours - all chrome - did you have it chromed or did you find it somewhere?

And - what ever documentation you have and are willing to share will be appreciated. I'm just getting started. 
Many Thanks, Clap
Tommy


____________________________________
Tommy
1980 Project Corvette - (Need suggestions)
1982 "Ruby" (Ain't She Sweet!)
 Reply Reply  Quote Reply w/Quote
6/5/11 9:37am - Reply: '82 Computer'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19449
Cleaning an engine with a pressure washer is not a good idea when you have a lot of electronic components involved. It's possible that some of the electronics were damaged, and that caused the problem to get worse. The TPS(Throttle position sensor), MAP(Manifold air pressure) sensor, and others are very sensitive to moisture. Unless you carefully covered all of the electrics when pressure washing, you may have more than just tune-up related problems. I would definitely start with the tune-up first, for sure...it sounds like it needs it anyway.
Wiring diagram will be on it's merry widdle way shortly.


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
6/5/11 9:42am - Reply: '82 Computer'
crossfire1982
Standard Member
- Send Private Message


Cramerton, NC - USA

Vette(s):
black 1982 coupe slate gray interior, 350 crossfire, 1985 fuel pump, Steeroids R&P conversion

Joined: 8/22/2006
Posts: 1094
I had the air cleaner chromed after looking for years for to find one.  I kept looking on ebay until I found one at a decent price and bought it, took it to a local chrome shop and they took care of the chrome work.   You have a PM
Crossfire19822011-06-05 06:52:07

____________________________________

Click for a larger image
Save The Wave


 Reply Reply  Quote Reply w/Quote
6/16/11 1:56pm - Reply: '82 Computer'
kwoody
Former Member
- Send Private Message


Tucson, AZ - USA

Vette(s):
1982 Black/Tan Leather Build Code C09E Bronze TTop CrossFire Fuel Injection L83 85 Fuel Pump Auto Axle 2.72 Firestone Firehawk Indy500

Joined: 7/11/2010
Posts: 415
Wow! 20 mpg?  Really?  What else have you done besides the Cat removal?  I have removed and cleaned the contacts on my 82 computer.  Not a bad idea.  I use Caig D5 contact cleaner.  The O2 sensor regularly flags on my 82.  It controls the enleanment and enrichen functions while in closed loop mode.  When it flags the system goes into enrichen and the limp home mode.  That is my understanding of it's function.

Keith


____________________________________

Nobody ever waves when I'm driving the Explorer.
K Woody
 Reply Reply  Quote Reply w/Quote
6/16/11 2:17pm - Reply: '82 Computer'
TommySSE
Former Member
- Send Private Message


Darnestown, MD - USA

Vette(s):
"Ruby", is my 1982 Candy Red - my Daily Driver

Joined: 1/1/2009
Posts: 32
Yes REALLY!  and I bet now that I gave her new E3 plugs, Accel wires, Accel corrected Dist. cap, Accel super duper coil, Moroso rotor, and a new ignition module. I bet she'll even do better on a long hwy trip.  That 20 mpg was 35%/65%  City/Hwy driving  (hwy cruising at 65-70mph average).  Its so mice to be able to push my toe into the pedal now.  She does seem to be running a little warmer then she use to though.

____________________________________
Tommy
1980 Project Corvette - (Need suggestions)
1982 "Ruby" (Ain't She Sweet!)
 Reply Reply  Quote Reply w/Quote
6/16/11 2:31pm - Reply: '82 Computer'
kwoody
Former Member
- Send Private Message


Tucson, AZ - USA

Vette(s):
1982 Black/Tan Leather Build Code C09E Bronze TTop CrossFire Fuel Injection L83 85 Fuel Pump Auto Axle 2.72 Firestone Firehawk Indy500

Joined: 7/11/2010
Posts: 415
Very Cool!  I'm working towards that but, here in Tucson I have to keep the Cat.  I'm just inside the emissions testing zone. (by 3 miles)  I have mostly been getting between 11 and 15 mpg.  I'm just before rebuilding the TBs and have just replaced the OEM fuel pump with a 85 model OEM pump. 
 
Keith



____________________________________

Nobody ever waves when I'm driving the Explorer.
K Woody
 Reply Reply  Quote Reply w/Quote
6/18/11 10:13am - Reply: '82 Computer'
chronos51
Former Member
- Send Private Message


Phoenix, AZ - USA

Vette(s):
1982 corvette crossfire production numer C5101985. Color is silver and claret. All original numbers match. slight mods to crossfire for better efficiancy and power balanced and added fuel pressure assembly between throttle bodies,

Joined: 6/12/2011
Posts: 139
[QUOTE=TommySSE]How do I check the operating status of the 82 Computer?Ouch
Engine running like its on 6 cylinders - step on the gas a little and it back fires through throttlebody, like it sneezed, and pinging like crazy on 93 octane.  Was running on regular really nicely getting 20mpg with plenty of power.
I tried unplugging the battery a couple of times hoping it would reboot/reset the computer - no difference noticed.  I'm pulling the plugs, wires, dist cap, and rotor cause I saw a lot of shorting between the plug wires. found plugs that seemed fouled.
Using an "action code scanner" (CP9001) - the code pumped out 12 = computer error. 
The previous owner removed the cats - so my guess is that the computer may have been tampered with, cause what would you do about the O2 sensor at the cat? my bet is that the computer is looking for that O2 data.

Advice?

Does C3VR forum have a photo library (searchable) for wiring diagrams and other points of interest?
[/QUOTE]
sounds to me your off timming, back fire through the tb seems like timming related. when I did the top end of my 82 I didnt get the timming right to begin with and it also backfired through the tb's.
is just a thought but perhaps your timming chain needs replaced not knowing how many miles are on your car and if it came on all of a sudden I would really look at your timming and check for vacuume leaks as well.
Marcus


____________________________________




 Reply Reply  Quote Reply w/Quote
7/25/11 1:31am - Reply: '82 Computer'
TommySSE
Former Member
- Send Private Message


Darnestown, MD - USA

Vette(s):
"Ruby", is my 1982 Candy Red - my Daily Driver

Joined: 1/1/2009
Posts: 32
OK - so I have an up date - I replaced the spark plugs with E3's (E3.42) - the spark plug wires with Accel 3000 series - the distributor cap with the Accel corrected cap, the rotor, the ignition module, and topped it all off with the Accel HEI in-cap Super Coils.  Didn't change anything else.  
She runs like a brand-new 1982.  I've had the opportunity to run a couple of tanks of gas through her with a combination of city and highway driving - she's getting an average of 18 miles per gallon on regular (87), and runs as smooth as silk.  Now about that computer check engine light - it has decided to go out.  This absolutely blows my mind - I'm not going to change a thing she runs to good.
TommySSE2011-07-24 22:33:22

____________________________________
Tommy
1980 Project Corvette - (Need suggestions)
1982 "Ruby" (Ain't She Sweet!)
 Reply Reply  Quote Reply w/Quote
7/25/11 3:35pm - Reply: '82 Computer'
kwoody
Former Member
- Send Private Message


Tucson, AZ - USA

Vette(s):
1982 Black/Tan Leather Build Code C09E Bronze TTop CrossFire Fuel Injection L83 85 Fuel Pump Auto Axle 2.72 Firestone Firehawk Indy500

Joined: 7/11/2010
Posts: 415
Hey Tommy,

Glad to hear you have Ruby running good!...  I've had success with Baby too.  The MAP went bad on me after 8 months or so.  I've changed the plugs installed the 85 pump and set the timing to 10* from 12* and found that the cruise control vacuum circuit was leaking badly.  Life is a lot better now.  Idles at 850-900 rpm after start up to 1200.  In gear at traffic lights now 650-750 rpm.  AC still works while stopped at lights.  That is very important here in the desert. I'm getting 18.5 mpg hwy and 16.25 mpg mix 30%/70% hwy/city.  Baby is running very smoothly now.

All the best!
Keith


____________________________________

Nobody ever waves when I'm driving the Explorer.
K Woody
 Reply Reply  Quote Reply w/Quote
7/26/11 11:06pm - Reply: '82 Computer'
kwoody
Former Member
- Send Private Message


Tucson, AZ - USA

Vette(s):
1982 Black/Tan Leather Build Code C09E Bronze TTop CrossFire Fuel Injection L83 85 Fuel Pump Auto Axle 2.72 Firestone Firehawk Indy500

Joined: 7/11/2010
Posts: 415
Tommy,

Don't know if you have seen this:
http://www.corvetteactioncenter.com/kb/questions/120/1982%3A+Service+Bulletin%3A+Spark+Plug+Fouling%7B47%7DDriveability


____________________________________

Nobody ever waves when I'm driving the Explorer.
K Woody
 Reply Reply  Quote Reply w/Quote
7/27/11 11:44am - Reply: '82 Computer'
TommySSE
Former Member
- Send Private Message


Darnestown, MD - USA

Vette(s):
"Ruby", is my 1982 Candy Red - my Daily Driver

Joined: 1/1/2009
Posts: 32
KWoody,

I had planned on researching new PROMs - so you poat is quite timely - Thank you Did you get one yet? does it really work as well as you expected?  And of course where did you get it?


____________________________________
Tommy
1980 Project Corvette - (Need suggestions)
1982 "Ruby" (Ain't She Sweet!)
 Reply Reply  Quote Reply w/Quote
7/27/11 7:08pm - Reply: '82 Computer'
kwoody
Former Member
- Send Private Message


Tucson, AZ - USA

Vette(s):
1982 Black/Tan Leather Build Code C09E Bronze TTop CrossFire Fuel Injection L83 85 Fuel Pump Auto Axle 2.72 Firestone Firehawk Indy500

Joined: 7/11/2010
Posts: 415
Hi Tommy, 

I have not checked  the number on my chip(PROM)  but, Baby was made the last week of Sep 82 so, it should have been part of production.  Mine will go into higher gear below 35-40 mph if I'm not stompin on her tail.

There were just over 600 C3s made after her.  I'll be pulling the back storage bins out soon to get to the windshield wiper controller so, I am planing to pull the ECM then to take a look. If I don't do that now during Monsoon season, I might not get to it until next year.  Does not rain much here. But.... When it rains, it really RAINS!

Keith
kwoody2011-07-27 16:10:17

____________________________________

Nobody ever waves when I'm driving the Explorer.
K Woody
 Reply Reply  Quote Reply w/Quote
7/27/11 11:36pm - Reply: '82 Computer'
TommySSE
Former Member
- Send Private Message


Darnestown, MD - USA

Vette(s):
"Ruby", is my 1982 Candy Red - my Daily Driver

Joined: 1/1/2009
Posts: 32
How do you find out when your car was made?  I think I would like to know when mine was made.
Thanks!


____________________________________
Tommy
1980 Project Corvette - (Need suggestions)
1982 "Ruby" (Ain't She Sweet!)
 Reply Reply  Quote Reply w/Quote
7/28/11 12:31am - Reply: '82 Computer'
kwoody
Former Member
- Send Private Message


Tucson, AZ - USA

Vette(s):
1982 Black/Tan Leather Build Code C09E Bronze TTop CrossFire Fuel Injection L83 85 Fuel Pump Auto Axle 2.72 Firestone Firehawk Indy500

Joined: 7/11/2010
Posts: 415
Hi Tommy,

Look inside the driver's door frame around the top hinge. You will see a plate.

I can't find the picture I took of Baby's plate right now.  I'll add it later.

Use the Research Tab here at C3VR and click on C3 Build Dates. Decode using the information there.   And there you have it.

Have fun!

Keith  Clap




____________________________________

Nobody ever waves when I'm driving the Explorer.
K Woody
 Reply Reply  Quote Reply w/Quote
 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
 Forums -> C3 Engines
(Moderator: Adam Wartell, Norsky, Adams' Apple)
 

 
Official C3 Vette Registry Community:
Home | Forums | Email | Who's Online | Clubs | Events | Member Stats

Other Official C3 Vette Registry Areas:
Members | Research | Shop | My Account | About C3VR
 

Corvette is a registered trademark of the General Motors Corporation(GM) & Chevrolet Motor Division. Vette Registries, LLC is responsible for all site content (except for member submitted content or where otherwise noted) and does not claim or imply that Chevrolet or GM is responsible for Official C3 Vette Registry content. Vette Registries, LLC is independent from GM and is not affiliated with, sponsored or supported by GM.  Copyright/trademark/sales mark infringements are not intended, or implied and are in fact used to support GM, Chevrolet and Corvette

Official C3 Vette Registry content is Copyright 2001-2017, Vette Registries, LLC. Content may not be reused without written consent. All Rights Reserved. NS

Corvette (Vette) Model Years on this site: 1968 1969 1970 1971 1972 1973 1974 1975 1976 1977 1978 1979 1980 1981 1982 30