C3 Vette Registry - The Best Resource on the Net for C3 Vettes! C3 Vette
Forums -> C3 Fuel, Emission Control, and Exhaust Systems
Not Logged In! Login or Register!  Users Online: 17 / Help 
Features  Find C3 Parts on ebay in only 2 or 3 clicks!  | Add YOUR C3 to the Registry

Supporting Vendors
VetteBookStore.com
CorvetteClothing.com
Bair's Corvettes
Mid America Motorworks
Volunteer Vette Products

C3 of the Month
None Current
Enter Yours Today!
Online C3 Show
13
C3s are Registered

Vanity Plates
GR8XCAPE
Chris81
Featured Links

Buy Now
Kindle
Kindle


Motor Trend - $5 for 12 issues.
Motor Trend
Only $5 for 12 issues.


Chevrolet Corvette Restoration Guide
Chevrolet Corvette Restoration Guide


How To Rebuild Corvette Rolling Chassis 1963-1982
How To Rebuild Corvette Rolling Chassis 1963-1982



| Hide Signatures and Profile Pics

 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
1/23/14 2:53pm - Original Message: '1982 Sending unit'
druzac
Limited Member
- Send Private Message


Joined: 12/6/2012
Posts: 14
Replaced my fuel pump and sending unit, now the guage is stuck on "E".
 
Any suggestions on what is wrong, without pullling the sending unit back out and checking to see of the ground wire did not come loose.
 
 
 Reply Reply  Quote Reply w/Quote
 
Support C3VR!
Suport our advertisers
1/23/14 10:20pm - Reply: 'Re: 1982 Sending unit'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19454
If you disconnect the  signal wire from the sender, the gauge should go to "Full". If it does, this tells you the wiring and the gauge are good. If it does not, the the sender is not the problem. It's definitely possible the ground got pulled loose installing the unit. Also possible the float is stuck on the front of the tank bladder,
How much fuel was in it when you swapped the sender? If the tank wasn't empty, then most likely the ground has come loose....Ouch


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
1/24/14 11:21am - Reply: 'Re: 1982 Sending unit'
druzac
Limited Member
- Send Private Message


Joined: 12/6/2012
Posts: 14
Had an inch of gas in the tank when exchange was made, so basically empty.  Before the guage would not go below 1/2 tank.  Inside of tank looked good, bladder intact, etc.....I was not surprised to see the needle at "E" when everything was hooked up, as thats where it should have been.  Now that the tank is full, it's still on "E".  Also, I can still hear the fuel pump running after shutoff.  I read somewhere that this could be a bad oil pressure switch causing pump to run.
 Reply Reply  Quote Reply w/Quote
1/24/14 12:54pm - Reply: 'Re: 1982 Sending unit'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19454
Hmmmm.....interesting. Looks like you may be needing to pull the unit back out and do a double-check.
The oil pressure sender does come into play for the fuel pump, BUT.....there should be no power to the fuel pump relay with the key off, so.....
Did you have this particular problem(fuel pump) before swapping the sending unit, or is that a new symptom? Does is just continue to run all the time with the key off, or does it stop running after a few seconds?


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
1/24/14 5:03pm - Reply: 'Re: 1982 Sending unit'
druzac
Limited Member
- Send Private Message


Joined: 12/6/2012
Posts: 14
Got it all going the right direction.....replaced the oil pressure switch.  Took out the sending unit and the ground had come off during the installation process.  Was dreading taking that out and back in, but went in alot smoother the second time.  Guess practicing helps.  All is working perfectly now, thanks for the input and advice.  You were spot on with the sender unplugged (needle pegged past full).
UPDATE: before the oil pressure switch was replaced, the fuel pump would run for several seconds (+/- 20 sec) before it would shut off after the car was turned off.  The oil pressure guage would bounce a little between 40-60.  After replacement, pump turns on for about 2 seconds prior to start up, and I dont hear it at all when I turn off the ignition.  The oil pressure guage is right at 40 at idle with no fluctuation.

|UPDATED|1/24/2014 3:03:07 PM (AZT)|/UPDATED|
 Reply Reply  Quote Reply w/Quote
1/24/14 10:50pm - Reply: 'Re: 1982 Sending unit'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19454
druzac said:  After replacement, pump turns on for about 2 seconds prior to start up, and I dont hear it at all when I turn off the ignition.


Clap Exactly as it should. Great! The pump should run only for a couple of seconds if you just turn the key on without cranking the engine. It should shut down as soon as you turn the ignition off. Guess your issues were both related. Glad you got it fixed! Thumbs Up


____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
 Forums -> C3 Fuel, Emission Control, and Exhaust Systems
(Moderator: Adam Wartell, Norsky, Adams' Apple, kstyer)
 

 
Official C3 Vette Registry Community:
Home | Forums | Email | Who's Online | Clubs | Events | Member Stats

Other Official C3 Vette Registry Areas:
Members | Research | Shop | My Account | About C3VR
 

Corvette is a registered trademark of the General Motors Corporation(GM) & Chevrolet Motor Division. Vette Registries, LLC is responsible for all site content (except for member submitted content or where otherwise noted) and does not claim or imply that Chevrolet or GM is responsible for Official C3 Vette Registry content. Vette Registries, LLC is independent from GM and is not affiliated with, sponsored or supported by GM.  Copyright/trademark/sales mark infringements are not intended, or implied and are in fact used to support GM, Chevrolet and Corvette

Official C3 Vette Registry content is Copyright 2001-2017, Vette Registries, LLC. Content may not be reused without written consent. All Rights Reserved. NS

Corvette (Vette) Model Years on this site: 1968 1969 1970 1971 1972 1973 1974 1975 1976 1977 1978 1979 1980 1981 1982 30