C3 Vette Registry - The Best Resource on the Net for C3 Vettes! C3 Vette
Forums -> C3 Fuel, Emission Control, and Exhaust Systems
Not Logged In! Login or Register!  Users Online: 21 / Help 
Features  Find C3 Parts on ebay in only 2 or 3 clicks!  | Add YOUR C3 to the Registry

Supporting Vendors
CorvetteClothing.com
Bair's Corvettes
VetteBookStore.com
Mid America Motorworks
Volunteer Vette Products

C3 of the Month
None Current
Enter Yours Today!
Online C3 Show
13
C3s are Registered

Vanity Plates
K10J
Owen
Featured Links

Buy Now
Kindle
Kindle


The Corvette Factories: Building America's Sports Car (Hardcover)
The Corvette Factories: Building America's Sports Car (Hardcover)


The Corvette Dynasty (Hardcover)
The Corvette Dynasty (Hardcover)


Corvette Fuel Injection & Electronic Engine Control: 1982 through 2001
Corvette Fuel Injection & Electronic Engine Control: 1982 through 2001



| Hide Signatures and Profile Pics

 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
8/3/13 4:30pm - Original Message: '82 crossfire injectors wont fire!! (solved)'
chronos51
Former Member
- Send Private Message


Phoenix, AZ - USA

Vette(s):
1982 corvette crossfire production numer C5101985. Color is silver and claret. All original numbers match. slight mods to crossfire for better efficiancy and power balanced and added fuel pressure assembly between throttle bodies,

Joined: 6/12/2011
Posts: 139
ok so my car ran great then I went to start it to go to work and no injector pulse.

 I am getting volts to both injectors, fuses are ok, fuel pump fuse is ok, fuel pump relay reads voltage at all pins- swapped relay with known good from under hood tested no pulse from injectors, fuel pump- took out hooked up ground and tapped hot wire to it and it turns on. Ecm fuse good, New Battery, good connections at distributor... Have a full tank of fuel

So now what? I am at a loss- checking the ignition system is next ie making sure I have spark to wires, control module on top of distributor is pretty new, oil pressure sending unit is hooked up
put fuel in throttle bodies fires right up. dies when fuel is gone. injectors arent firing at all...Plugged fuel filters??

any thoughts any ideas that I missed?

thanks
marcus

after hours of searching the net for solutions, removing fuel pump and tracing all my wires I found this post

they say 20 amp fuse but mine is a 30 amp fuse. I will be replacing the entire unit in the morning to a more sealed unit.


30 amp fuse block in rear compartment bad connection, checked fuse was fine ,wiggled fuse injectors fired, fuel pump relay clicked, fuel pump turned on, injectors fired work, car fires right up no issues












|UPDATED|8/3/2013 2:30:54 PM (AZT)|/UPDATED|


____________________________________




 Reply Reply  Quote Reply w/Quote
 
Support C3VR!
Suport our advertisers
8/3/13 2:30pm - Reply: 'Re: 82 crossfire injectors wont fire!!'
rraider1
Former Member
- Send Private Message


Woodland, WA - USA

Vette(s):
1977 T-Top,350,Auto Black Ruby Pearl,Steeroids R&P conversion

Joined: 10/14/2003
Posts: 1152
have you checked for a fault code ?
 
Check out the info here
 


____________________________________
Bob R
 Reply Reply  Quote Reply w/Quote
8/3/13 3:33pm - Reply: 'Re: 82 crossfire injectors wont fire!!'
chronos51
Former Member
- Send Private Message


Phoenix, AZ - USA

Vette(s):
1982 corvette crossfire production numer C5101985. Color is silver and claret. All original numbers match. slight mods to crossfire for better efficiancy and power balanced and added fuel pressure assembly between throttle bodies,

Joined: 6/12/2011
Posts: 139
when i put fuel in the throttle bodies the check engine light doesnt stay on but I will run a check on the system anyways

Ground pin "A" to "B" turn key to on position..... Check engine light should flash to recognize diagnosis mode.... no  nothing. ECM issue???
 used jumper wire to test "check engine" light- light works but computer will not recognize field service mode.






|UPDATED|8/3/2013 1:33:55 PM (AZT)|/UPDATED|


____________________________________




 Reply Reply  Quote Reply w/Quote
8/9/13 12:02pm - Reply: 'Re: 82 crossfire injectors wont fire!! (solved)'
vettejack Lifetime Member
Lifetime Member
- Send Private Message


Titusville, FL - USA

Vette(s):
1977 Coupe (White), 1982 Coupe (Silver), 2006 Convertible (Victory Red). NCM Life Member #2221.

Joined: 12/19/2007
Posts: 142
I had a similiar issue with my 82...but keep in mind my 'fix' may not be your fix. Since I didn't see what had happened to me within your issue, we want to make sure it has not been overlooked either.
 
I pretty much had all the symptoms you mention...the car would start right up, then quickly die like it was 'starving for fuel. I 'threw' parts at it with my mechanic and just about replaced everything you mention as well up on/around the manifold.
 
We're braining storming thinking what we might have forgotten to troubleshoot. So, we go back to the fuel. Once we decided to take out the pump again is when the issue was found. The teflon clamps from the pump to the fuel line were weak and one broken. The broken teflon clamp allowed the hose to elongate/stretch thereby sending fuel, and some of its pressure, right back into the fuel tank. Our fix: put in a new length of hose and replace the teflon clamps with regular metal hose clamps.
 
Results? Problem solved...car runs like a champ. This issue is elsewhere on this site explained there as well. Good luck!! 


____________________________________
 Reply Reply  Quote Reply w/Quote
8/9/13 12:09pm - Reply: 'Re: 82 crossfire injectors wont fire!!'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19454
chronos51 said: Ground pin "A" to "B" turn key to on position..... Check engine light should flash to recognize diagnosis mode.... no  nothing. ECM issue???

Not necessarily...if there are no codes stored, the light will not flash any. Not sure on the '82, but normally, when you jumper the pins, and there are no codes, the light will flash a "12" code(one flash, followed by two quick flashes) repeatedly, meaning there are no codes. I'd have to check to see if the '82 systems would do that or not, unless someone else here knows for sure.



____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
8/9/13 12:13pm - Reply: 'Re: 82 crossfire injectors wont fire!! (solved)'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19454
chronos51 said:
30 amp fuse block in rear compartment bad connection, checked fuse was fine ,wiggled fuse injectors fired, fuel pump relay clicked, fuel pump turned on, injectors fired work, car fires right up no issues

That is probably due to the location of the fuse, near the battery....out-gassing of the battery can cause some corrosion, and create 'lectrical maladies like that. I would suggest cleaning as best you can the fuse blades, with some sandpaper, and then maybe using a little dielectric grease on them before putting them back in....that will help keep the terminals from corroding. Thumbs Up




____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
8/9/13 12:17pm - Reply: 'Re: 82 crossfire injectors wont fire!! (solved)'
chronos51
Former Member
- Send Private Message


Phoenix, AZ - USA

Vette(s):
1982 corvette crossfire production numer C5101985. Color is silver and claret. All original numbers match. slight mods to crossfire for better efficiancy and power balanced and added fuel pressure assembly between throttle bodies,

Joined: 6/12/2011
Posts: 139
Adams' Apple said:
chronos51 said:
30 amp fuse block in rear compartment bad connection, checked fuse was fine ,wiggled fuse injectors fired, fuel pump relay clicked, fuel pump turned on, injectors fired work, car fires right up no issues

That is probably due to the location of the fuse, near the battery....out-gassing of the battery can cause some corrosion, and create 'lectrical maladies like that. I would suggest cleaning as best you can the fuse blades, with some sandpaper, and then maybe using a little dielectric grease on them before putting them back in....that will help keep the terminals from corroding. Thumbs Up




ive actually replaced the fuse holder with a more weather resistant one that caps the fuse itself, i left the original fuse holder for the looks (stock) and rewired the new one in and concealed it. 




____________________________________




 Reply Reply  Quote Reply w/Quote
8/9/13 12:20pm - Reply: 'Re: 82 crossfire injectors wont fire!!'
chronos51
Former Member
- Send Private Message


Phoenix, AZ - USA

Vette(s):
1982 corvette crossfire production numer C5101985. Color is silver and claret. All original numbers match. slight mods to crossfire for better efficiancy and power balanced and added fuel pressure assembly between throttle bodies,

Joined: 6/12/2011
Posts: 139
Adams' Apple said:
chronos51 said: Ground pin "A" to "B" turn key to on position..... Check engine light should flash to recognize diagnosis mode.... no  nothing. ECM issue???

Not necessarily...if there are no codes stored, the light will not flash any. Not sure on the '82, but normally, when you jumper the pins, and there are no codes, the light will flash a "12" code(one flash, followed by two quick flashes) repeatedly, meaning there are no codes. I'd have to check to see if the '82 systems would do that or not, unless someone else here knows for sure.



Due to the ecm fuse not working that also links into the fuel pump relay and the fuel pump the ecm had no power to it, with out proper power it was reading nothing. once I replaced the corroded fuse holder and fuse the Ecm flashed code 12 and nothing else due to disconnection.

 





____________________________________




 Reply Reply  Quote Reply w/Quote
8/9/13 12:22pm - Reply: 'Re: 82 crossfire injectors wont fire!! (solved)'
chronos51
Former Member
- Send Private Message


Phoenix, AZ - USA

Vette(s):
1982 corvette crossfire production numer C5101985. Color is silver and claret. All original numbers match. slight mods to crossfire for better efficiancy and power balanced and added fuel pressure assembly between throttle bodies,

Joined: 6/12/2011
Posts: 139
vettejack said: I had a similiar issue with my 82...but keep in mind my 'fix' may not be your fix. Since I didn't see what had happened to me within your issue, we want to make sure it has not been overlooked either.
 
I pretty much had all the symptoms you mention...the car would start right up, then quickly die like it was 'starving for fuel. I 'threw' parts at it with my mechanic and just about replaced everything you mention as well up on/around the manifold.
 
We're braining storming thinking what we might have forgotten to troubleshoot. So, we go back to the fuel. Once we decided to take out the pump again is when the issue was found. The teflon clamps from the pump to the fuel line were weak and one broken. The broken teflon clamp allowed the hose to elongate/stretch thereby sending fuel, and some of its pressure, right back into the fuel tank. Our fix: put in a new length of hose and replace the teflon clamps with regular metal hose clamps.
 
Results? Problem solved...car runs like a champ. This issue is elsewhere on this site explained there as well. Good luck!! 
Thanks for the input its greatly appreciated, but when I had the fuel pump out i checked for looseness on it and gave it direct bat power to test the pump itself.
Was a corroded fuse in the battery compartment, that I did correct. 
thank you so much for the advice though


____________________________________




 Reply Reply  Quote Reply w/Quote
 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
 Forums -> C3 Fuel, Emission Control, and Exhaust Systems
(Moderator: Adam Wartell, Norsky, Adams' Apple, kstyer)
 

 
Official C3 Vette Registry Community:
Home | Forums | Email | Who's Online | Clubs | Events | Member Stats

Other Official C3 Vette Registry Areas:
Members | Research | Shop | My Account | About C3VR
 

Corvette is a registered trademark of the General Motors Corporation(GM) & Chevrolet Motor Division. Vette Registries, LLC is responsible for all site content (except for member submitted content or where otherwise noted) and does not claim or imply that Chevrolet or GM is responsible for Official C3 Vette Registry content. Vette Registries, LLC is independent from GM and is not affiliated with, sponsored or supported by GM.  Copyright/trademark/sales mark infringements are not intended, or implied and are in fact used to support GM, Chevrolet and Corvette

Official C3 Vette Registry content is Copyright 2001-2017, Vette Registries, LLC. Content may not be reused without written consent. All Rights Reserved. NS

Corvette (Vette) Model Years on this site: 1968 1969 1970 1971 1972 1973 1974 1975 1976 1977 1978 1979 1980 1981 1982 30