C3 Vette Registry - The Best Resource on the Net for C3 Vettes! C3 Vette
Forums -> C3 Interior
Not Logged In! Login or Register!  Users Online: 10 / Help 
Features  Find C3 Parts on ebay in only 2 or 3 clicks!  | Add YOUR C3 to the Registry

Supporting Vendors
Volunteer Vette Products
VetteBookStore.com
CorvetteClothing.com
Mid America Motorworks
Bair's Corvettes

C3 of the Month
None Current
Enter Yours Today!
Online C3 Show
13
C3s are Registered

Vanity Plates
REARN2GO
rearn2go72
Featured Links
Chevrolet Corvette Restoration Guide


Buy Now
Corvette Fifty Years (Hardcover)
Corvette Fifty Years (Hardcover)


Corvette by the Numbers
Corvette by the Numbers


Corvette from the Inside
Corvette from the Inside


Kindle
Kindle



| Hide Signatures and Profile Pics

 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
3/6/15 4:08am - Original Message: 'speedo working intermittently'
daveo76
Former Member
- Send Private Message


Vancouver, WA - USA

Vette(s):
1976 Silver/Firethorn. L48, 4spd. Original 2 bolt, vortec heads, 9.4:1 CR, Speed Pro Cam: 224/224@0.050, 112 LSA, Eagle Steel Crank.

Joined: 8/25/2005
Posts: 831
My speedo is working only intermittently.  Cold mornings seem to be the worst.  When it's not working there's a noise coming from the transmission tunnel - presumably it's the cable's attachment at the tranny.  Any thoughts?  I would think if something was physically broken down there the speedo would never work, not intermittently work.  I've not had a chance to put it up in the air to take a look - maybe it will be obvious once I do so?  

____________________________________

 

1976 Silver/Firethorn.  L48, 4spd.  Original 2 bolt, vortec heads, 9.4:1 CR, Speed Pro Cam: 224/224@0.050, 112 LSA, Eagle Steel Crank.
 Reply Reply  Quote Reply w/Quote
 
Support C3VR!
Suport our advertisers
3/6/15 9:45am - Reply: 'Re: speedo working intermittently'
my7t1 Lifetime Member
Lifetime Member
- Send Private Message


Dorr, MI - USA

Vette(s):
71 Colonnade Hardtop Coupe Torch Red with black interior originally L48 built to push around 360hp

Joined: 8/21/2002
Posts: 2580
I had the same intermittent problem with mine. The cable was worn on the ends. Replaced it and it works fine. Not too bad of a job. "T"

____________________________________

Click on images for Before and After pics!
 Reply Reply  Quote Reply w/Quote
3/6/15 11:08pm - Reply: 'Re: speedo working intermittently'
dwright Gold Member
Gold Member
Moderator
- Send Private Message


Victor, NY - USA

Vette(s):
2004 Commemorative Edition Coupe, Auto w/HUD. 13K miles in 2015. Sold 1982 Red Coupe

Joined: 7/12/2004
Posts: 6768
They need to be relubed regularly. Disconnect at the tranny, remove the inner cable, use special lube, slide it back in.
If the end is twisted, you will need to replace the cable. If you have cruise control, the lower cable is not too difficult. If not, the connection behind the dash is tricky, but can be done. Don't hurt your back.


____________________________________

Save the Wave!
Support the National Corvette Museum   
 Reply Reply  Quote Reply w/Quote
3/9/15 2:15am - Reply: 'Re: speedo working intermittently'
daveo76
Former Member
- Send Private Message


Vancouver, WA - USA

Vette(s):
1976 Silver/Firethorn. L48, 4spd. Original 2 bolt, vortec heads, 9.4:1 CR, Speed Pro Cam: 224/224@0.050, 112 LSA, Eagle Steel Crank.

Joined: 8/25/2005
Posts: 831
Thanks guys.  No CC in '76 so my cable is one piece.  I replaced it when I did the engine a few years ago - probably not much more than 1K miles on it.  So I'm concerned it's more of an installation problem than a wear problem.  I think I'm just gonna have to get it up in the air so I can figure what's going on.  I got tangled up doing a rear brake job on my suburban (drums, ugh) this weekend so I ran out of time.  Will keep you posted...

____________________________________

 

1976 Silver/Firethorn.  L48, 4spd.  Original 2 bolt, vortec heads, 9.4:1 CR, Speed Pro Cam: 224/224@0.050, 112 LSA, Eagle Steel Crank.
 Reply Reply  Quote Reply w/Quote
3/9/15 12:51pm - Reply: 'Re: speedo working intermittently'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19523
daveo76 said: So I'm concerned it's more of an installation problem than a wear problem.

Yer prolly on the right track with that idea. If the ferrel for the cable is loose where it connects to the speedo adapter, OR the speedo adapter itself is loose, it can cause those exact issues...noise, and erratic speedo. Being a 4 sped car, it should have the 90deg adapter/ratio corrector on it right out of the trans, and the cable attaches to the adapter. Yer gunna hafta crawl under there and have a look....Ouch



____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
3/10/15 1:27am - Reply: 'Re: speedo working intermittently'
daveo76
Former Member
- Send Private Message


Vancouver, WA - USA

Vette(s):
1976 Silver/Firethorn. L48, 4spd. Original 2 bolt, vortec heads, 9.4:1 CR, Speed Pro Cam: 224/224@0.050, 112 LSA, Eagle Steel Crank.

Joined: 8/25/2005
Posts: 831
Thanks, Joel.  Yep, gotta do an oil change anyway so it'll be up on the ramps or jack stands in the near future and I'll check it out.  'cept now you have me worried - I'm not sure I remember there being a 90 degree adapter on the tranny for it.  If not, maybe that's my problem.  

____________________________________

 

1976 Silver/Firethorn.  L48, 4spd.  Original 2 bolt, vortec heads, 9.4:1 CR, Speed Pro Cam: 224/224@0.050, 112 LSA, Eagle Steel Crank.
 Reply Reply  Quote Reply w/Quote
3/10/15 10:45pm - Reply: 'Re: speedo working intermittently'
Adams' Apple Lifetime Member
Lifetime Member
Moderator
- Send Private Message


Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas

Joined: 11/8/2003
Posts: 19523
It will look like dis un, if ya has it. MOST 4 speeds used the adapter, but it might depends on what rear end ratio the car has.



____________________________________
Joel Adams
C3VR Lifetime Member #56    
My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
 Reply Reply  Quote Reply w/Quote
 New Topic New Topic Post Reply Reply New Poll New Poll Search     Search Page [1]  
 Forums -> C3 Interior
(Moderator: Adam Wartell, Norsky, Adams' Apple)
 

 
Official C3 Vette Registry Community:
Home | Forums | Email | Who's Online | Clubs | Events | Member Stats

Other Official C3 Vette Registry Areas:
Members | Research | Shop | My Account | About C3VR
 

Corvette is a registered trademark of the General Motors Corporation(GM) & Chevrolet Motor Division. Vette Registries, LLC is responsible for all site content (except for member submitted content or where otherwise noted) and does not claim or imply that Chevrolet or GM is responsible for Official C3 Vette Registry content. Vette Registries, LLC is independent from GM and is not affiliated with, sponsored or supported by GM.  Copyright/trademark/sales mark infringements are not intended, or implied and are in fact used to support GM, Chevrolet and Corvette

Official C3 Vette Registry content is Copyright 2001-2018, Vette Registries, LLC. Content may not be reused without written consent. All Rights Reserved. NS

Corvette (Vette) Model Years on this site: 1968 1969 1970 1971 1972 1973 1974 1975 1976 1977 1978 1979 1980 1981 1982 30