Home page

Cool! NEW FEATURE! Add "Your Corvette Story" today

C3 Cooling and Heating Systems

a/c (1/4)
 6/21/17 11:46am
dwa175Gold Member
Gold Member
Send Private Message

oakville, CT - USA

Vette(s):
1979 coupe and now 2007 c-6


Joined: 7/19/2014
Posts: 192

I need to get to port on accumulator but cant coolants is blocking  can I loosen coolant bottle for room or do I need to remove bottle,yes this is a r-12 system,no I am not going to update to r-234,problem is ac comp doesn't go off runs all the time with ac on   cause mybe low coolant level  I need to check this frist   ac works fine always has  .how to I get to coolant bottle.thanks  dwa

______________
Our Sponsors help support C3VR
Sponsor Ad

Re: a/c (2/4)
 6/21/17 9:18pm
stingrayjim jrLifetime Member
Lifetime Member
Send Private Message

SHELBYVILLE, TN - USA

Vette(s):
1976 L48 auto

1978 L82 4speed

1994 LT1 6speed


Joined: 7/5/2002
Posts: 3942

Definately check the system first for correct pressure.  If it runs all the time (when its turned on) and blowing cold air, then i dont really see a problem...however, if its icing up, creating ice on the lines near the evaporator, or backside of the compressor, then there is probably a refrigerant level issue,or blowing hot air and the compressor is turning then the pressure switch may be at fault..... if its all good, the compressor will run all the time when the clutch is activated(turn on a/c or defrost in cabin)....  pressure-wise, with a set of gauges the low side(suction side, usually near the evaporator) should run in the neighborhood of 30-35 ish psi....   if it falls below around 26 psi the pressure switch will deactivate the power going to the compressor's clutch, stopping the compressor....

hope that helps a little


Re: a/c (3/4)
 6/21/17 11:07pm
73shark
Standard Member
Send Private Message

Overland Park, KS - USA

Vette(s):
1973 Orange Metallic Coupe (orig owner), L82, 4 spd (WR), PS, (A/C & PW (I installed from wrecked 73)), leather, AM/FM Stereo, ran with '65 FI unit earlier & will again some day.


Joined: 7/9/2003
Posts: 554

I cussed GM every time I had to hook up to the port down there.  It did some good as on the '74, they moved it up in line along the fender.  May do that when I put mine back together.

______________

1973 L-82 4 spd

Re: a/c (4/4)
 6/22/17 9:52am
dwa175Gold Member
Gold Member
Send Private Message

oakville, CT - USA

Vette(s):
1979 coupe and now 2007 c-6


Joined: 7/19/2014
Posts: 192

you are correct  problem is getting to a/c port,every items check but coolant level   has anyone have a idea how to get to this port.

______________