Home page

Topic: Expert Needed: Fuel Pump signal NOT coming from ECM - hair pulling!

in Forum: C3 Electrical

Expert Needed: Fuel Pump signal NOT coming from ECM - hair pulling! (1/4)
 5/30/20 3:43pm
vettzGold Member
Gold Member
Send Private Message

Joined: 2/26/2006
Posts: 3

Hi,  Bought a 1982 with a fuel pump signal problem... if I jumper the relay pump works and engine pops off!

 

What I have tried so far:

  1. confirmed orange wire by battery (20amp fuse) is ok
  2. replaced ecm same condition
  3. replaced the fuel pump relay

Can somebody tell me where to look for possible issue with wiring? I have probed to connector on ecm and no signal

also confirmed that ground has continuity to ecm..  Please help 🤒

Our Sponsors help support C3VR
Re: Expert Needed: Fuel Pump signal NOT coming from ECM - hair pullin (2/4)
 5/30/20 9:06pm
Adams' AppleLifetime Member
Lifetime Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas


Joined: 11/8/2003
Posts: 19733

Without looking at a wiring diagram. or knowing what specific code(s) you have, I would venture to guess you have an oil pressure sending unit problem. The ECM looks for oil pressure to ground the fuel pump relay, as well as an ignition signal. One or the other...or both, can cause the pump to play dead.



______________
Joel Adams
C3VR Lifetime Member #56    

My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
Re: Expert Needed: Fuel Pump signal NOT coming from ECM - hair pullin (3/4)
 5/30/20 11:15pm
vettzGold Member
Gold Member
Send Private Message

Joined: 2/26/2006
Posts: 3

Thank you Joel! been trying everything, and it was tough to track down!  ended up being corroded fuse for ECM power!  what the hell  LOL  My journey just beginning with this one 😂

Re: Expert Needed: Fuel Pump signal NOT coming from ECM - hair pullin (4/4)
 5/31/20 9:01am
Adams' AppleLifetime Member
Lifetime Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas


Joined: 11/8/2003
Posts: 19733

It's always something silly, right? lol



______________
Joel Adams
C3VR Lifetime Member #56    

My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
Our Sponsors help support C3VR