Home page

Topic: No turn signals

in Forum: C3 Electrical

No turn signals (1/14)
 6/9/10 6:10pm
spielman5Lifetime Member
Lifetime Member
Send Private Message

ANCHORAGE, AK - USA

Vette(s):
1965-327 coupe, 1968-small block coupe, 1969-427, 1971-454 coupe and currently a 1976-ZZ4 coupe reborn again,and hotter than ever.. Add a 1996 CE LT-4 for backup


Joined: 10/12/2004
Posts: 2193

Ok gents lets help me fix this..Disapprove.
 
I took the car to the Alignment Center yesterday, they did their work and on the way home I had no turn signals??..I checked the fuse box first, all lit up with tester, next I checked all bulbs and they all work, next I purchased a replacement #522 long life flasher and installed it..No turn signals?? I hate chasing these ghosts..Wacko There are two wires on the passenger side under the dash that the flasher hooks into, one wire is pink and one purple, I think one goes back to the fuse box and the other heads up under the dash, I'm not taking the dash appart..Censored.. is there suppose to be power to the flasher by one of the wires?? If I there is suppose to be power and I have none, can I tap into a power source and hook it to the flasher wire?? Make sense?? Any ideas, all ideas welcome and become the property of the under signed........ Terry Spielman,
 
 better known as The penguin to many Texans ..Wits End...Lost in Alaska....send Help..
 
Oh by the way the 4 way emergency flashers do work..
 
spielman52010-06-09 15:22:19
Our Sponsors help support C3VR
No turn signals (2/14)
 6/9/10 9:42pm
yostusota
Former Member

Send Private Message

York, PA - USA

Vette(s):
1969 daytona conv. all original 350 350 380 4 sp w/air..and hard top


Joined: 5/18/2010
Posts: 1518

Sounds like a column switch problem..if you hook power to the relay without the column switch they won't turn off..just flash and flash..put a test light to the column connector and see if you can make it flash with the column lever..or if you have power even there..if not it's a broken wire between the column and the fuse box..is so then check to see if you can make a test light flash at the relay on either wire using the column lever..it probably won't though because the 4 ways work..might be a bad connection at the column connector..start there and see what you find..not to hard though..worst case is that you run a wire from the cold side of the fuse box to the column connector..r replace the switch under the steering wheel.

good luck
Rich


______________

My first parade at Carlisle 2010
No turn signals (3/14)
 6/9/10 11:23pm
Adams' AppleLifetime Member
Lifetime Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas


Joined: 11/8/2003
Posts: 19733

Terry...do the lights come on but not flash, or do they not come on at all?

The flasher should NOT have power to it unless the turn signals are on...
Adams' Apple2010-06-09 20:25:57

______________
Joel Adams
C3VR Lifetime Member #56    

My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
No turn signals (4/14)
 6/10/10 12:30am
spielman5Lifetime Member
Lifetime Member
Send Private Message

ANCHORAGE, AK - USA

Vette(s):
1965-327 coupe, 1968-small block coupe, 1969-427, 1971-454 coupe and currently a 1976-ZZ4 coupe reborn again,and hotter than ever.. Add a 1996 CE LT-4 for backup


Joined: 10/12/2004
Posts: 2193

Joel,
 
No turn signal indicators light up in the dash when I turn on the key and try to signal??
spielman52010-06-09 21:32:39
No turn signals (5/14)
 6/10/10 1:43am
rraider1
Standard Member
Send Private Message

Woodland, WA - USA

Vette(s):
1977 T-Top,350,Auto Black Ruby Pearl,Steeroids R&P conversion


Joined: 10/14/2003
Posts: 1152

I believe there should be power to the pink wire with the key on, the flasher gets a grnd through the column switch to the lt bulbs to ground.
No turn signals (6/14)
 6/10/10 8:00am
Adams' AppleLifetime Member
Lifetime Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas


Joined: 11/8/2003
Posts: 19733

dohRight you are, Bob...Ouch
Pink/white wire comes directly from fuse box. Purple wire comes from t-sig switch...
No power on the pink/wht wire means a break in the wire from the fuse box, or a bad fuse. The fuse can check ok with a test light, but the connection can be bad coming out of the fuse box. Try removing the fuse and re-installing, or just replace the fuse with a new one...


______________
Joel Adams
C3VR Lifetime Member #56    

My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
No turn signals (7/14)
 7/23/10 12:47pm
jose's 79
Former Member

Send Private Message

bethpage, NY - USA

Vette(s):
stock original 1979 L82.


Joined: 7/19/2010
Posts: 34

i am have the same problem with my 79. i have hazard lights, no turn lights. i plugged in a new turn switch and still no turn signals. put in a new fuse also still not working. i switched the fuse with the hazard fuse, and the fuse is good. 
No turn signals (8/14)
 7/23/10 12:55pm
Adams' AppleLifetime Member
Lifetime Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas


Joined: 11/8/2003
Posts: 19733

Try another flasher, or swapping the t-sig flasher with the hazard flasher.
Do the turn lights come on, but just don't blink, or do they not come on at all?


______________
Joel Adams
C3VR Lifetime Member #56    

My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
No turn signals (9/14)
 7/23/10 1:47pm
jose's 79
Former Member

Send Private Message

bethpage, NY - USA

Vette(s):
stock original 1979 L82.


Joined: 7/19/2010
Posts: 34

i switched the flashers and the turns still don't work. i get nothing, don't come on, don't stay on, nothing.
No turn signals (10/14)
 7/24/10 11:06am
DaveMLifetime Member
Lifetime Member
Send Private Message

Flanders, NJ - USA

Vette(s):
1982 Black, ZZ4, Hooker Side Pipes, 3.55 Rear, Rebuilt & upgraded 700R4, All new suspension, brakes, & new Charcoal interior.


Joined: 1/27/2004
Posts: 2533

Hey Terry, why do you need turn signals? Isn't there only ONE road up where you live.Rolling On The Floor Laughing
 
Good luck with the problem.
Dave


______________
 

Lifetime Member #116
Dave's '82


   
No turn signals (11/14)
 7/25/10 9:27am
jose's 79
Former Member

Send Private Message

bethpage, NY - USA

Vette(s):
stock original 1979 L82.


Joined: 7/19/2010
Posts: 34

my car doesn't have the Capacitor, is that a problem? what does it do and do i need it? now the car wont start. think it might be a problem with the ignition switch that is next to the turn switch because nothing connected to the ignition is working P/W P/locked radio. could that be the problem?
No turn signals (12/14)
 7/25/10 9:45am
lukesvetteLifetime Member
Lifetime Member
Send Private Message

HOWELL, NJ - USA

Vette(s):
1979, Targa Blue (72 Color), Pace Car rear spoiler, L88 hood, Dark blue factory interior, 525HP 406, HD 700R4, 370 gears,Steeroids, composite rear spring, TT IIs wrapped in T/A Radials.


Joined: 5/18/2004
Posts: 6810

I had a similar problem. Turned out to be a combination of a dirty terminals at the bulbs and an old flasher that was still working but was probably 25 years old and past its useful life. Cleaned everything up, new flasher and things started blinkin again...

Look for the simple stuff first before assuming that wiring has gone bad - a test light at the bulb sockets didn't read anything until I really probed through the grime to the good copper... 
No turn signals (13/14)
 7/25/10 5:36pm
jose's 79
Former Member

Send Private Message

bethpage, NY - USA

Vette(s):
stock original 1979 L82.


Joined: 7/19/2010
Posts: 34

i put new flashers the hazards work and switched flashers so i know they are good. the flashers work they are the same bulbs.
Re: No turn signals (14/14)
 4/29/20 1:09pm
riccig
Limited Member
Send Private Message

Howey In The Hills, FL - USA

Vette(s):
1979 Coupe and 2017 Stingray


Joined: 4/29/2020
Posts: 1

For my 1979 Corvette the turn signals did not light up or blink and all dash lights went off.  Upon replacing the turn signal flasher, the turn signals lit up and blinked and all dash lights came on.  This information did not appear anywhere in the owner's manual or factor assembly manual so perhaps it is unique to the wiring in my car which doesn't look to be hacked and in original condition.

Our Sponsors help support C3VR