Home page

Topic: Weird dash lights issue

in Forum: C3 Electrical


Already a Member?
Login
Not yet a Member?
Register for Free!

Weird dash lights issue (1/2)
 10/21/21 8:53pm
BillHanna
Standard Member
Send Private Message

Cana, VA - USA

Vette(s):
1975 Stingray 71 350 engine Flat top pistons Sniper fuel injection Hyperspark ignition Vintage Air air conditioning Borgeson power steering box


Joined: 7/3/2016
Posts: 266

I'm usually pretty good at tracking down electrical issues, but this one has me stumped -- don't really know where to start.

Sometimes, only when the headlights are on, both turn signal indicators on the dash will come on steady, when this happens the panel lights for the speedo & tach go out, and the high-beam indicator goes on.  This happens randomly, and I don't know how long this has been an issue because I seldom drive it at night.

I assume it must be a ground issue where the ground is feeding back through the turn signal indicators, but why only when the headlights (and not the parking lights) are on?  As far as I know, there is no link between the headlight circuits and the turn signal indicators.

Any ideas?

 

You may have noticed the color change on my '75 -- my wife never liked the rainbow paint job, and I was a bit bored this past week. . .



______________

   

Our Sponsors help support C3VR
Re: Weird dash lights issue (2/2)
 10/21/21 10:43pm
F4Gary
Standard Member
Send Private Message

Grapevine, TX - USA

Vette(s):
1972 LT-1 convertible with factory air.


Joined: 8/26/2006
Posts: 1133

BillHanna said:

You may have noticed the color change on my '75 -- my wife never liked the rainbow paint job, and I was a bit bored this past week. . .


Your wife has good taste.....

😍



______________

Our Sponsors help support C3VR