Home page

C3 Electrical

windshield wipers (1/5)
 12/5/18 11:43am
legsdiamond
Standard Member
Send Private Message

St. Louis, MO - USA

Vette(s):
1976 Corvette


Joined: 2/5/2010
Posts: 48

My 1976 C3 windshield wiper only work on high speed and will not shut off. Does that mean my wiper motor is bad?

Thanks
Our Sponsors help support C3VR
Sponsor Ad

Re: windshield wipers (2/5)
 12/5/18 10:25pm
Adams' AppleLifetime Member
Lifetime Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas


Joined: 11/8/2003
Posts: 19646

I would suspect the wiper switch itself first. 

______________
Joel Adams
C3VR Lifetime Member #56    

My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
Re: windshield wipers (3/5)
 12/6/18 2:45am
73shark
Standard Member
Send Private Message

Overland Park, KS - USA

Vette(s):
1973 Orange Metallic Coupe (orig owner), L82, 4 spd (WR), PS, (A/C & PW (I installed from wrecked 73)), leather, AM/FM Stereo, ran with '65 FI unit earlier & will again some day.


Joined: 7/9/2003
Posts: 557

Or a bad connection or broken wire.

______________

1973 L-82 4 spd

Re: windshield wipers (4/5)
 12/6/18 10:16am
BillHanna
Standard Member
Send Private Message

Cana, VA - USA

Vette(s):
1975 Stingray


Joined: 7/3/2016
Posts: 164

Mine only worked on Hi, but it did shut off okay.  I found that someone had added about 8 inches to the three wires under the dash and crossed them in the process.  It took me quite a while to track that down.  Whoever had this car in the past had hacked most of the wires under the dash -- I can't imagine why. . .



______________
 
  
  
Re: windshield wipers (5/5)
 12/8/18 11:30pm
legsdiamond
Standard Member
Send Private Message

St. Louis, MO - USA

Vette(s):
1976 Corvette


Joined: 2/5/2010
Posts: 48

Ok, I'll try swapping switch out first.

Thanks