Home page

Topic: Idle low in drive at traffic light

in Forum: C3 Engines


Already a Member? Click Here to Login
Not yet a Member? Click Here to Register for Free!
Idle low in drive at traffic light (1/5)
 6/3/21 4:05pm
Babyblue 78
Standard Member
Send Private Message


Vette(s):
1978 Corvette Light Blue Pulled from the swamps of Miami! Its a driver and back on the road!


Joined: 12/3/2007
Posts: 272

So my 78 L44 I drove yesterday to my mechanic to discuss a problem with the hood latch release.(more on that later). Driving over there the car ran fine and idled fine. In returning home at the red light in Drive the tach dropped to 500rpm and the car would shake like crazy. Moving the shift into park the idle returned to 900 and the car ran smooth. Once under way the car would run perfectly fine and smooth. Returning to a stop sign the car would drop idle again to 500 and shake like crazy. Into park the car idled perfectly. My mechanic is backed up until end of June cause not one wants to work. I was going to a car show on this Saturday but would really like to try and fix this quickly.  I talked to him and he said try looking at the idle advance vac system. Ok I'm not a gear head so yes I think I can find it and check the hose but does anyone have a trouble shooting checklist for this item or experienced it with some help tips???  I go to maybe 2 car shows a year to take my car and Murphy likes to go also but causes problems! All suggestions are greatly appreciated.

 

Babyblue 78

Our Sponsors help support C3VR
Re: Idle low in drive at traffic light (2/5)
 6/3/21 5:06pm
73shark
Limited Member
Send Private Message

Overland Park, KS - USA

Vette(s):
1973 Orange Metallic Coupe (orig owner), L82, 4 spd (WR), PS, (A/C & PW (I installed from wrecked 73)), leather, AM/FM Stereo, ran with '65 FI unit earlier & will again some day.


Joined: 7/9/2003
Posts: 674

If you had the A/C running at the time, the first thing I would check is the idle stop solenoid.  It's located on the driver's side of the carburetor and should extend when the A/C is turned on and retract when it's turned off.



______________

1973 L-82 4 spd

Re: Idle low in drive at traffic light (3/5)
 6/4/21 8:52am
Babyblue 78
Standard Member
Send Private Message


Vette(s):
1978 Corvette Light Blue Pulled from the swamps of Miami! Its a driver and back on the road!


Joined: 12/3/2007
Posts: 272

AC has been inop since I bought the car.  I will try and check the vacuum hoses today.  Unless the idle itself is too low in the Park position to start with.

 

Babyblue 78

 

Re: Idle low in drive at traffic light (4/5)
 6/4/21 3:05pm
Babyblue 78
Standard Member
Send Private Message


Vette(s):
1978 Corvette Light Blue Pulled from the swamps of Miami! Its a driver and back on the road!


Joined: 12/3/2007
Posts: 272

So I finally looked under the hood. As per suggested I first went to the Distributor and the line out was attached, but not connected to the first Diaphragm which I'm assuming is the Vacuum Advance. Once attached the car started and idled properly in all Drive positions and park.  A very simple fix and glad that is all. Thanks again for any input to this matter.

 

Babyblue 78

Re: Idle low in drive at traffic light (5/5)
 6/4/21 4:25pm
73shark
Limited Member
Send Private Message

Overland Park, KS - USA

Vette(s):
1973 Orange Metallic Coupe (orig owner), L82, 4 spd (WR), PS, (A/C & PW (I installed from wrecked 73)), leather, AM/FM Stereo, ran with '65 FI unit earlier & will again some day.


Joined: 7/9/2003
Posts: 674

FWIW, the idle speed is supposed to be adjusted with a transmission in Drive, A/C off, and the idle stop solenoid denergized. If the A/C is functional, you would do the same procedure with the transmission in Drive, the A/C on, which should cause the idle stop solenoid to be energized.



______________

1973 L-82 4 spd

Our Sponsors help support C3VR