Home page

Cool! NEW FEATURE! Add "Your Corvette Story" today

C3 Engines

Motor Quit (1/4)
 6/23/17 1:29pm
Vetteman75
Former Member

Send Private Message

Wetumpka, AL - USA

Vette(s):
1975 Stingray Coupe 2014 Stingray Convertible


Joined: 1/9/2014
Posts: 16


Hey everyone I gave my son my 75 Corvette as a present for spending 20 years in the military (I am retired too).  Original motor and Tranny.  Today he was driving it to work.  He said it was purring like a kitten.  All of a sudden he felt it loosing power.  Pulled over to the side of the road.  Says it would turn over and not start.  Says he checked the oil, gas, and coolant before he left.  He thought he would let it cool while he called the wrecker to take it back home.  He thinks it blew up.  I ask him was he running it hard or getting on it and he said no.  He is 39 years old and in the Air Force.  He knows he had one bad ass Vette.  Anyway while waiting he tries to turn it over again and nothing.  It has a brand new battery in it.  I told him if it blew you would have heard one hell of an explosion plus smoke would have filled the cabin and out the headers.  Any suggestions as to what to look for?  I told him to take the plugs out and turn it by hand to see if the valves are moving.  If not the Timing Change broke.  Anyway we might be in the market for a new motor and tranny...Thanks for any advice.  Dean



|UPDATED|6/23/2017 10:29:28 AM (AZT)|/UPDATED|


______________
Our Sponsors help support C3VR
Sponsor Ad

Re: Motor Quit (2/4)
 6/23/17 4:47pm
Adams' AppleLifetime Member
Lifetime Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
#1-1974 L-48 4spd Cp Med Red Metallic/Black deluxe int w/AC/tilt/tele./p/w-p/b/ Am-Fm/map light National/Regional/Chapter NCRS "Top Flight" #2-1985 Bright Red/Carmine Cp.L-98/auto Member: NCRS, NCRS Texas, Corvette Legends of Texas


Joined: 11/8/2003
Posts: 19639

Sounds like the ignition module may have given up the ghost. First check to see if the plugs are getting any fire. If not, check to see that the distributor is getting 12v. If that all checks good, then make SURE the carb has fuel....just because the tank is full doesn't mean the fuel is getting to the carb. THEN go into the engine to see if the valves are moving. Thumbs Up

______________
Joel Adams
C3VR Lifetime Member #56    

My Link


(click for Texas-sized view!)
             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
Re: Motor Quit (3/4)
 6/23/17 11:50pm
73shark
Standard Member
Send Private Message

Overland Park, KS - USA

Vette(s):
1973 Orange Metallic Coupe (orig owner), L82, 4 spd (WR), PS, (A/C & PW (I installed from wrecked 73)), leather, AM/FM Stereo, ran with '65 FI unit earlier & will again some day.


Joined: 7/9/2003
Posts: 554

Also check to see if the distributor rotor is turning to check for broken timing chain or gear.  My '73 stripped the teeth off the crank gear and that was all she wrote.

PS: Thank you both for your service.  USN '65-'69 here.

|UPDATED|6/23/2017 8:50:25 PM (AZT)|/UPDATED|


______________

1973 L-82 4 spd

Re: Motor Quit (4/4)
 6/30/17 1:04pm
nosal1Gold Member
Gold Member
Send Private Message

Dunedin, FL - USA

Vette(s):
1980 Corvette Torch Red with Gold metallic 370HP/350 CU.IN.Turbo 350 w/shift kit.Originally CA.Car with 305 CU.IN.


Joined: 3/21/2006
Posts: 252

Sounds like the module gave up.You might want to get a new module and capacitor..I have had this happen many times in different cars/truck with OEM HEI.Good luck            nosal